Softaculous and CageFS

Sometimes when installing CloudLinux after Softaculous is installed Softaculous is unable to detect PHP versions outside of the server’s native PHP installation.
The following steps need to be taken to configure the pre_install hooks for Softaculous to recognize alt-php from the command line:

# cp /usr/local/cpanel/whostmgr/docroot/cgi/softaculous/enduser/hooks/pre_install_cagefs{.txt,.php}
# cp /usr/local/cpanel/whostmgr/docroot/cgi/softaculous/enduser/hooks/pre_upgrade_cagefs{.txt,.php}
# cp /usr/local/cpanel/whostmgr/docroot/cgi/softaculous/enduser/hooks/pre_clone_cagefs{.txt,.php}

After performing the above Softaculous should now detect the PHP version each cPanel account is using via PHPSelector.

This procedure only works for cPanel servers.

Leave a Reply

Your email address will not be published. Required fields are marked *